CCF Editor User Guide
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Installation

Install CCFEdit8 by double clicking on CCF Editor 8.exe

B8 setup - CCF Editor version - X

Select Additional Tasks
Which additional tasks should be performed?

Select the additional tasks you would like Setup to perform while installing CCF Editor, then click Next.

Additional shorteuts:
[~ Create a desktop shortcut

Next > Cancel

Click Next to begin the installation.

B setup - CCF Editor version _

Ready to Install
Setup is now ready to begin installing CCF Editor on your computer.

Click Install to continue with the installation, or click Back if you want to review or change any settings,
Additional tasks:

Additional shortcuts:
Create a desktop shortcut

< Back Install Cancel

Click on Install to install the editor to the default location.

B setup - CCF Editor version

Completing the CCF Editor Setup Wizard

Setup has finished installing CCF Editor on your computer. The application
may be launched by selecting the installed shortcuts.

Click Finish to exit Setup.

[ Launch CCF Editor

Finish

Ensure that ‘Launch CCF Editor’ is checked before clicking Finish.

The editor will launch the following Window only.
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® GetHWID

b60ac650-be37-530e-ad73-1961a20ad48f

Click on Copy to Clipboard and paste into an email, send to reggraham5@gmail.com

Once you have received the license file launch CCFEdit8 by double clicking the shortcut created by
the installer

The first window to appear will be the Language selection window shown below
® Select Language

Language English E

OK

Select the language from the dropdown box and press OK.

If the launch check box was not checked and you have not already applied for and received the
license file, then at license Window press close and perform the steps below.

e Select Help->GetHWID the window below will be displayed.
[ NN

31455ce77-b57f-305e-8c3b-3e943ae0ff2a

o (CopyroClipioard | Fxit
e Click on Copy to Clipboard and paste into an email, send to reggraham5@gmail.com

Start CCFEDIT at the below screen press change license.
Select the file supplied and press open the next window will appear.

N
® e
- FC CAis 1 icanmean Validasia,m
® 0

CCF Edit License Validation

License 150560100955817

Name far =ma=c

E-Mail = _o=ronGRspeTTEE T =

HWID: b60ac650-be37-530e-ad73-1961a20ad48f
License Status License OK

o

This screen will show the license details press close and then close CCFEDIT.

CCF Edit is now ready for use, if however the license window appears again this sometime happens
just repeat the license entering process again.

CCF Editor V8 Settings
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CCF Edit supports tabbed or windows operating mode
Select File->Settings at the following window the options fore Use Windows, Hide MDF Value and
Language are available.

(&) *
[] Use Windows Language (English -
[v] Hide MDF

To use tabbed mode uncheck ‘Use Windows’ and to show the MDF Value uncheck Hide MDF.
The language can be selected from the drop down box.
Click on OK to save the settings.

Using the editor standalone (download/upload)

The editor has the ability to download the VBF file directly from the DFSM server and when edited
save and upload to the DFSM server.

Windows Mode or Tabbed Mode:

Click on File->Download, this will open the VIN entry window as below.
[ ] [ ] VIN Number

Enter VIN Number: sal-

Enter the VIN and click on OK. If the vbf downloads successfully it will either load automatically or
open the following chooser window. For all models covered buy Pathfinder the chooser window will
display.

® As-Is or As-Built

Choose As-Is or As-Build

DASEN As-Built

Windows Mode:
In Windows mode only one file may be downloaded at a time.

2 CCF Edit vA.0 SADCAZANNL - 0o X
File Edit Dump Help en
# Parameter | Description Vvalue Description
1 EUCD001 VEHICLE TYPE X761 -
2 EUCD002 DOORS 5 Door =]
3 |EUCD003 [TRANSMISSION DRIVELINE _All Wheel Drive (Without disconnect)
4 |[EUCDO004 BIFUEL |Not Bifuel
5 |[EUCDO005 |ENGINE TYPE AJ200D OR AJ21-D4 2.0 litre (4 Cylinder)
il EUCDO006 FUEL Diesel
7 EUCD007 ALTERNATOR Alternator 2304
9 |[EUCD008 |STEERING WHEEL POSITION |Right Hand Drive
10 |[EUCD003 GEARBOX \ZF 8 Speed Automatic Gearbax
11 |[EUCDO10 |GEARBOXTYPE |Automatic gearbox
12 EUCDO11 FUEL TANK VOLUME Fuel Tank Small (50L)
13 EUCD012 ALARM ot supported
14 [EuCD013 |SEAT MASSAGE |Seat Massage not Fitted
15 |[EUCD014 HEADLIGHTS TYPE |Gas Discharger Lights with auto. adj
17 |[EUCD015 HEADLIGHTS SYMMETRY |Not Supported
18 EUCD016 DAYRUNNING LIGHT Standard dipped light (Mon-DTRL)
19 EUCDO17 DIMMED DIPPED HEADLIGHTS Not supported
20 [EUCDO18 |[FOGLIGHT FUNCTION [Faglight without restrictions
21 |[Fucpo1a |REAR FOGLIGHT TOW FUNCTION |Faglights shut off when trailer is connected only trailers...
22 EUCD020 TRAILER MODULE Without Trailer Module
23 EUCDO21 KEYLESS ENTRY AND START Keyless Eniry And Start
25 EUCD022 ADDITIONAL HEATER Without fuel fired heater
26 [FuCD023 |CRUISE CONTROL (Cruise Control
27 |[EucD024 |RAINSENSOR |Not supported
28 EUCD025 HEADLIGHT CLEANING Not supported
29 EUCD026 POWER STEERING TYPE Eleciric Power Steering with extemal torque conirol only,
30 |EucDo27 [TRIP COMPUTER |Witnout Trip computer
31 [EucDo28 PRIVATE LOCKING TRUNK |Private locking trunk.
41 EUCD029 |CHILD LOCK REAR DOORS |Elecirical child lock rear doors
42 EUCD030 UNLOCK SETTING Two step opening
43 EUCDO031 ACKNOWL SIGNAL LOCK ALARM Not supported
44 EUCD032 |AUTOMATIC LOCKING BY SPEED Not supported =
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Tabbed Mode:
In Tabbed mode up to three files can be downloaded at a time.

2 CCFEditv80 - ul X
E Edit Dump Help en
Open LASS x| SADCAZAWSSSS e % | SADCAZAX4RS e
Compare | oarameter | Description Val.. Description
Download  £UCD001 _[VEHICLE TYPE 0x18 X761 |~
save UCD002  |DOORS 0x02 |5 Door =]
Save As UCD003  |TRANSMISSION DRIVELINE 0x02 |All Wheel Drive (Without disconnect)
UCD004 _|BIFUEL 0x01 Not Bifuel
Print UCDO05__|ENGINE TYPE 0x98 AJ200D OR AJ21-D4 2.0 litre (4 Cylinder)
Settings UCD006  |FUEL 0x02 Diesel
Exit UCD007 _ |ALTERNATOR 0x0C | Alternator 230A
wmoerw—EUCDO08 _|STEERING WHEEL POSITION 0x02 Right Hand Drive
0x0237 [10 [EUCD00% |GEARBOX 0x4A ZF 8 Speed Automatic Gearbox
0x0247 [11_[EUCDO10 _|GEARBOXTYPE 0x02 Automatic gearbox
0x0257 [12 [EUCDO011__|FUEL TANK VOLUNME 0x0B [Fuel Tank Small (50L)
0x0267 13 [EUCDO1Z |ALARM 0x00 |Not supportad
010277 |14 |EUCDO013 | SEAT MASSAGE 0x01 |Seat Massage not Fitted
0x0287 [15 [FUCDO14 | HEADLIGHTS TYPE 0x03 |Gas Discharger Lights with auto. adj
0x0327 [17_|[EUCDO15  |HEADLIGHTS SYMMETRY 0x00 Not Supported
0x0337 18 |EUCDO16 | DAYRUNNIMG LIGHT 0x02 |Standard dipped light (Non-DTRL)
010347 19 |[EUCDO017 | DIMMED DIPPED HEADLIGHTS 0x00 Not supported
0:0357 20 |[EUCDO18 _|FOGLIGHT FUNCTION 0x02 [Foglight without restrictions
0x0367 |21 |EUCDO019  |REAR FOGLIGHT TOW FUNCTION 0x02 Foglights shut off when traller is connected only trailers foglights are ru..
0x0377 |22 [EUCD020 _[TRAILER MODULE 0x01 [Without Trailer Module
0x0387 23 |[EUCD021 _|KEYLESS ENTRY AND START 0x02 [Keyless Entry And Start
0x0427 |25 |EUCD022  ADDITIONAL HEATER 0x01 Without fuel fired heater
00437 [26 [EUCD023 |CRUISE CONTROL 0x02 Cruise Control
0x0447 |27 |[EUCD024 |RAINSENSOR 0x00 [Not supported
0x0457 |28 [EUCDO25 |HEADLIGHT CLEANING 0x00 |Not supportad
0x0467 [29 [EUCD026 |POWER STEERING TYPE 0x08 Electric Power Steering with external torque control only_only for JLR.
0:0477 30 [EUCDO027 _[TRIP COMPUTER 0x01 |Without Trip computer
0x0487 |31 |EUCD028 |PRIVATE LOCKING TRUNK 0x02 |Private locking trunk
00527 |41 [EUCD029  |CHILD LOCK REAR DOORS 0x03 Electrical child lock rear doors
0:0537 |42 |[EUCD030 _|UNLOCK SETTING 0x02 Two step opening -

The As-Is file contains the last version uploaded to the DFSM server by Pathfinder or the CCF editor.
After making any edits as required the file can be Uploaded to the DFSM server. Click on File and the
Upload as shown below.

o0e® CCF Edit v
ZILW Edit Dump Help
Open FUCDODT — VERICLE TvPE
Compare EUCDD02 DOORS
Copy to EUCD003 TRANSMISSION DRIVELINE
Download  [Eucpoos BIFUEL
Save EUCD00S ENGINE TYPE
Save As EUCDD06 FUEL
[ Upload  ENendW [ALTERNATOR
- EUCD00S STEERING WHEEL POSITION
Print EUCDO009 GEARBOX
Exit EUCDO10 IGEARBOXTYPE
599 12 EUCDO11 FUEL TANK VOLUME
615 13 EUCDD12 [ALARM
631 14 EUCDO13 SEAT MASSAGE
647 15 EUCDO14 HEADLIGHTS TYPE
807 17 EUCDO15 HEADLIGHTS SYMMETRY
823 18 EUCDO16 DAYRUNNING LIGHT
839 19 EUCDO17 DIMMED DIFPED HEADLIGHTS

The VBF file will be automatically saved if required and then uploaded to the DFSM server.
It is also possible to copy a downloaded file to either SDD or Pathfinder using the Copy To open from
the file menu, this is not a necessity when using Pathfinder as it will automatically load the As-Is file

on VIN read.

The Upload and Copy to options are not available unless a file has been downloaded from the
server.
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Compare VBF Files

It is possible to compare two vbf files of the same generation the maximum number of compare
windows or tabs is one. In either mode it is possible to start without any vbf loaded by selecting
File->Compare the first file opened will be loaded into the window or first open file tab.

The second file opened will be used to compare against the first and either a window will open or a
tab will appear as shown.

Window Mode:

ene SADCAZAXAKATE=S59 - SADCAZAKIHASSSDwS

MOF | Parameter | Description val | Setting |val | setting

295 [EUCDOOL | VEMICLE TYPE (018 X761 0x18_ X761

311 [EUCDOOZ | DOORS (0x02 |5 Daor 0x02 |5 Door

327 [EUCDOO3 | TRANSMISSION DRIVELINE (0x02 |nll wheel Drive (Without discannect) [0%02 | All Wheel Drive (Without disconnect
FUCD004  BIFUEL [0x01 Not Bifuel 0x01_Not Bifuel

STEERING WHEEL POSITION (0x02_Right Hand Drive. Right Han Drive
GEARBOX [OxdA ZF B Speed Automatic Gearbox ZF 8 Speed Automatic Gearbox
|CEARBOXTYPE (0x02 Automatic gearbox Awtomatic gearbax

FUEL TANK VOLUME 0x00 Mot supported Not supported

|0x01 [Seat Massage not Fitted 201 | Seat Massage not Fitted

HEADLICHTS SYMMETRY [0%00 |Not Supported [0x06 | Not Supported
DAYRUNNING LIGHT (0%02 |Sandard dipped light. (Non-OTRL} {0x02 Standard dipped light. (Non-DTRL)
DIMMED DIFPED HEADLICHTS 0x00 Not supported 0x00_Not supported

EUCDO19 | REAR FOGLIGHT TOW FUNCTION 10%02 |Foglights shut off when wailer is connected only wale... 0x02 |Foglights shut off when trailer is connected only tra
[EUCD020 [ TRAILER MODULE | Module [0x01_|Without Trailer Module
EUCDO21 | KEYLESS ENTRY AND START | 0302 |Keyless Entry And Start

1063 EUCD022  ADDITIONAL HEATER 0x01 Without fuel fired heater 0x01 |Without fuel fired heater

1095 EUCDO24 | RAINSENSOR. |0x00 Not supported |0x00 | Not supperted
1111 EUCD025 HEADLIGHT CLEANING 0x00 Mot supported 0200 | Not supported

1143 EUCD027 | TRIP COMPUTER 0x01 | Witheut Trip computer 0501 Without Trip computer
1159]EUCD028 _ PRIVATE LOCKING TRUNK [0x02 |Private locking trunk [0x02 | Private locking trunk
1319/EUCDD29  CHILD LOCK REAR DOCRS |0x03 |Electrical child lock rear daars |0x03 | Electrical child lock rear doors

1335/EUCDD30 _ UNLOCK SETTING (0x02 [Two step opening 0x02_[Two step opening
1351 EUCD031 | ACKNOWL SIGNAL LOCK ALARM (0x00 Mot supported 000 | Not supported
1367|EUCD03Z | AUTOMATIC LOCKING BY SPEED (0x00 Not supported [0x00_|Not supported
1383|EUCD033 _ LEVEL SENSOR_IF ALARM (0x02_With level sensor [0x02_|With level sensor

1398 EUCDO34 | Key lock In Protection? EXT [0x04 |Ext scan for key prior/post to tailgate closure - both ... 0x04 | Ext scan for key prior/post to tilgate closure - bot...
1415 FUCDO35 _ Key lock in Protection INT [0x03 Interiar Scan for ANY KEY IN VEHICLE 1o 0403 | Interior Scan for ANY KEY IN VEHICLE to prevent cha...
1575 EUCDOI6 | PANIC ALARM [0x00 Not supported 0%00 | Not supported

1591 EUCD037 | BLIND SPOT INFORMATION SYSTEM |0x06 Blind Spot Information System with RTD (Rear raffic ... |0x06 | Blind Spet Information System with RTD (Rear trafiic...
1607 EUCD038_|ROAD FRICTION DETECTION [0x01 Without Road Friction 2 0x01_ Without Road Friction Detection System

1623 EUCDO30 _ PTC HEATER SUPPLEMENTARY AIR HEATER [0x02 With PTC heater 0x02_With FTC heater

1639 FUCDOA0 | BATTERY REAR |0%00 [Not supported 0x00 |Not supported

1655 EUCDO41 | COUPE FILTER |0x00 Mot supported [0x00 | Not supported
1671 ELCDO42  CLIMATE CONTROL UNIT 10x09 |Dual Zone ATC 0x0% |Dual Zone ATC
1831 EUCDO43  SPEED LIMITATION (0x00 | Not supported 0x00 | Not supported
1847 EUCDO44 |SPEED WARNING DEVICE [0x00 |Not supported {0208 |Not supported
.
Tabbed Mode:
[ 3 coe st an — O x| 3 coesean - o =x
Flie Edt Dump Help Show All en || File Edit Dume Help | ¥ Show AN en
SADCAZM wd24] = SADCAIMS—EITE x | SADCAZANGS - SADCAZASS el 241 - SADCAZAWSSSSS1878 x SADC 4241 8 SADC AR A SADC A - X SADE S B 141 - SADC Asm 1228 3
DR val val | [P Dascnpion v semng va semng

arametsr
EUCDoM R

Sattng
AI200D 3.0 ire (5 Ci
[No Altemator ited

[ Descrpu )

ENGINE TYPE A2200D OR AJ21-042._j0

ALTERHATOR [Abemator 2304 o
RANSWISEION DRVELINE

Frond Seal 565 Wassag

Matn LED F 8123148

Eucoots

0 EUCDO15_HEADLIGHTS SYMMETRY i hol Suppode
il Tow Ao 9337 __EUCDA16_DAVRUNNING LIGHT dard dpped ight (NonDTRL]

[With Retraciable Miers o EUCDA17 DMUED DIFFED HEADUCHTE
Wm amory
= connact
Josn

Niot supporied

e Trp computer
i Prafe ledkng

ICD428_(CHILD L Eiediical ik lock T Eiecr dles

[EUCEI30 HLGEK SETTRG % Tuen stop apening - Tova siep opening =

=
In both Window mode an Tabbed mode there is a show all check box as shown above, uncheck to

show just the differences between the files.

To compare files held on the DFSM server in Tabbed mode download them into the first two tabs.
Compare only operates on the first two tabs if the first tab has been closed compare will request to
open a file.
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Using CCF Editor directly with Pathfinder

Start Pathfinder in the normal way, once start-up has completed and the VIN has been read and all
modules loaded minimise Pathfinder.

In Windows or Tabbed mode click File->Open. As this is being used with Pathfinder the default
directory will be the location Pathfinder.

o0 e CCF Edit v7.0
File Edit Dump Help en
MOF 2 | Parameter Value Desariptian |
|£| Open VBF File *
oo [ - @EEEE
[ hsperfdata_reggr 3 SALRAZANTHASSS®SS extrac)
] jna-108392575 D SALRAZ e Sasrs=m? VBF

=3 MicrolmageDir

3 MicroThemePackDir

[ nio-file-upload

17 SADCA2AX 48w "5 _extracted |

4] I 1M IC

File Name: | |

Files of Type: |VBF files | = |

| Open H Cancel ‘

Double click the directory with the vehicle VIN ending in *_extracted’.
| £ Open VEBF File >

Look In: ‘ﬁ SADCAZANS 2598 extracted ‘V‘ E

[ SADCA2AXSwe==s==9 VBF

File Name:  [SADCAZAX#===5573 VBF |

Files of Type: |\rBF files | - |

| Open || Cancel ‘

Click open on the vbf file as shown above.
Edit the chosen parameter and click Update.
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‘ane CCF Edit- SADCAZAX S

| Descrigtion |value | Description I
EUCD179 NEUTRAL CONTROL AUTO. GEAR. Dx00__ Nat suppoted
leucoiso RPM SPEED CONTROLLER X0 Mot suppocted
lEucp181 DAMP SENSOR 0x02__ Damp Sensor idirect tw climate control ECU)
EUCD162 ASTHNA AND ALLERGY Dx00 Mot suppocted
leucpis3 ENGINE COOLING FAN PERFORMANCE 0x08Electric Fants)
Jeuco1ss GLOBAL OPEN/CLOSE 0x00_ Not supported
EUCD165 TRIP COMPUTER MIXED UNITS Dx02_ MPL Units Awailable For Section By Drwer
|EuCD186 DOOR REMOTE CONTROL CHANNEL TYPE 0x02__ Door Remote Muki Channel
EUCD187 AUIGIO BUTTONS STEERING WHEEL 0x02_ Audio Buttors In Steering Wheel
EUCD188 HANDSTREE TELEMUTE FUNCTION OX01 Without Telemuts Function
|eucp18y Shift imo Park Apphy Ox04__Shiftimo Park Apply Enabled Shift out of Park Release Enabled
EUCD190 Rear Door Sunblings D1 Withoun Rear Dave Birds
leucpial DRNVER IMPARMENT MONITOR 0x01 Without Drlver Impairmment Monor
Jeucp19z CITY SAFETY 0x00__Not supported
EUCD193 PS5 Wareng Stategy Dx0Z_Dual Leve Strategy
leucpias Mirror mounted win signal 0x02__ Mirror mounted wen signal
Jeucoias Hyrrie Trip Computer Power Ratia ©x00__ Power Ratio nen applicable
EUCD195 an Contact Tasgte 0x00 Undefined
leucpiar Climate Zore User Layout 0x02 2 Temperature 1 Disuibution 1 Biower
EUCD198 Eco Info System D15 Narmal Wehicle ~ enperial Gallon - 5 Seats
EUCD199 WGHTVSION 0X00 Not Configured
[eucpz00 Telematics L OxIF  Telematics TCU fined
EUCD201 REVERSE GEAR CHIVE Dx00 Nat suppoted
leucpzo2 Solar Sensor 0x03From - Dual Zone : Rear - Not Fined
leucoaas Telematics Pratection

Telematics Proteced
Nat suppocted
Mai

EUCDZ04 RETRACTABLE RUNNING BOARD

" oy T
|EUCD208 STEERING COLUMN LOCK 0x00 Not sup ported

T T e T

|EucDzLl BATTERY MOMITOR SENSOR: D102 Bauery Manitur Sensoe

e . T

JEUCD213 Eco Data Diiver Information Display x4 Function enabled (Display Information level 31

EUCDZL5 Infotainnent Theft Protection ~ Jaguar R-Type

|Eucpz1e Quiescern Relay Box | Ford $-TOCI

~ Jaguar RS sub-brand

cucDzLs IGOR System Description |
JEuco2Ly LANGUAGE REGION | s L
cuco220 SIDE CAMERA © Range Raver RS
|Eucp221 Trailer Tyre Press Monitoring System _ Jaguar 5 Sub-brand
G o i SV LE Sub-brand
EUCD205RACINGSUBBRAND ox01 Mainstream Vehicle []
Cancel (RSN
ene CCF Edit- SADCA ZAvS—
irs | Paramater | Descripsion |Vabue | Deseription 1 |
268 [EUCDL79 NEUTRAL CONTROL AUTO. GEAR 0x00 Nt supported
269 [EUCD180 REM SPEED CONTROLLER 0300 ot supported
270 eCo1A1 OANP SENSOR 0302 [Damp Sensor (dinectto chmate cancral £€L)
21 evcoa: ASTHME AND ALLERGY 0x00 Nt support
273 ewcoss ENGINE COOLING FAN PERFORMANCE 0x08_Elecinc Fanis)
270 eUCDLES ‘GLORAL OPEN /CLSE 0300 ot supported
275 ewcouss TAIP COMPUTER MIKED UNITS 0x02|MPL Urits Avalable For Seiection By Drver
276 ewcoLss 0OOR REMOTE CONTROL CHANNEL TVPE 0302 Door Remate Wi Charmal
217 [EUCD187 AUDIO BUTTONS STEERNG WHEEL 0302 usti utins n Stering whel
278 Euco1as HANDSSREE TELEUTE FUNCTION 0301 Without Tolemute Funchon
279 [ECDLES it o Park Aoty (304 St into Pars Apply Enabled Shif out o #ark Reiease Erabied
261 [evco1ao fuear Dacr Suntimds %01 wihout Rear Door Bieds
282 evcoran DRIVER IMPARMENT MONITOR 0301 Without Drwer Impaement Moniior
263 [eCD142 CITY SAFETY 0300 ot supported
264 |evco1a3 #55 Warning Serstegy x02Dual Level Sraegy
205 eco1ae Mirror meunted turn signal 0302 paerar mourted turn signal
286 [ECD14S Hybrid Trip Computer Pawer Ratio 0300 Pawer faun rat apglcable
207 EuCo196 o Caneact Taigate 0x00lndefmed
207 |eCD1a7 Clemate Zane User Layaus 0x02 |2 Temperaturs 1 Distrbution 1 Ekamer
208 eco1as Cen infa System (w15 |Normal vencle - impenial Galln - § Sears
298 [euco198 NCHTVEION 0300 ot Confgured
300 [ECD200 Talematcs | OmiFTelemanes Tou fed
301 [evcozal RLEVERSE CEAR GHINE 0x00|Nor supported
302 [evcozaz Salar Sensor 0303 Front - Dual Zae - Rear - Not Fitied
303 [EUCD203 Telematics Prorection 0303 Telemancs prozecied
308 LETRACTALLE RUNNING BOARD x00 supporied

ci & lag:
7751|307 |EUCD206 Drwver Workload Manager 0xb0__ |t supported

7767|308 eucozar CANERA Oxb1  |Without Frort Cameras

7781 (308 eucozos STEERING COLUMN LOCK. 0xb0 [Not supporied

7756 (310 |euco209 Wade Sensing Gxd1[{0001) Wade Sensing Nee fired
78S 311 ELCDZi0 BATTERY @xb3[T7 B0AR 700 Cold Cranking Ampere
7875 (313 ELCD21L BATTERY MONITOR SENSOR 0xD2_[Batery Montor Sensor

7901 (314 eucoa12 REGION IF OVD 0xD3 [R2 EUfSouth Afriea For OVD.

BLO7 (315 eucoziy Eco Data Driver Information Display x4 [Funciion enabled (Display Informaticn level 1)
8023 (316 EUCD214 INTEGRATED CONTROL PANEL 0x03[Extended IC)

BDIG (317 EUCDZLS Infatainmer Theft Protectian 0xb0 [Not supported

BOSS (318 ELCD21E Guiescent Relay bon 0xb2|ORB funciion enabled

8071 (318 eucn217 PICTURE SUPPORT. (GxD1|Without Picture Support

B231 (321 |eucozis JGOR System Descriptian Oxb1 |2 Relay with Dumb g

8247 (322 ELCD219 LANGUAGE RECION 0x00_|Nat supported

8263 (323 |eUcD220 SIOE CAMERA 0xD1|Without Side Camera

B279 (324 eucozz1 Traller Tyre Press Manoring System 0xb0 [Nt supported

8295|325 |EucD222 STOP START 0x02__[Stop/Seart

BILI (326 |euCD223 Head Up Display OxB1|HUD ot fed

8127 (327 ELCD224 ADJUSTABLE SPEED LMITER. 0xD2|ASL fited

B487 (337 |EUCD22S "Advanced Chaufieur Function (0xD1_|AFC ot Fined

B503 338 EUCDZZ6 [inteligeri Emergency Braking 0xb1_|Without LSE8

Click on File->Save to save back to the original file to use imfnediately or SaveAs to use at a later
time.
Click on the File->Exit, if the file has not been saved the following screen will appear click cancel and

try the Save again.
i Confirm Quit

CCF not saved - Are you sure you want to quit?

? - o

Minimize CCF Editor and Restore Pathfinder, select Service from the side menu.

(s

Guded Diagnor

VN

Model year o ECU Diagnostics

Odometer 14978 m ks,

Engine 204PT - 20 AJ200P Petrol
Transmission Automat

Oriver RHD

Body style

Trim

Job card number 100000

Campaigns

l ©  JaguarF-Pace X761 (DolP) VIN SAD CA2AXAK AR5l Mool year 2010 Odometer 14978 mi @ Biwem 120V

Click on ‘Select CCF'.
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I PP PR o 2733 b AR,

Powsrirain Control Module [PCM] F § Limé - Enab L~ <
dule [PCM] Mistre - Cylindes ideabtc
on
Senvice Message Resst
Tire siza {roling Greumierance)
|
Campaigns

| @  Jaguar F-Pace X761 (DolP)  VIN SAD CAZAXAK 055853 Mods| year 2010 Odometer 14078 mi © Givem 129V ‘

Click Next and select the ‘As Built’ option.

= ECU Diagnostecs. Servce Select CCF

@ Please seiect one of e fallowing optiens:

(@ JaguarFPace X761 (DolP) Vik SAD CAZAXIK ASSSESS ol yoar 2019 Odometer 14878 mi Q) @)l 121V

Click Next and foIIow the on-screen instructions to complete the upload to the car.
On completlon seIect guided diagnostics from the S|de menu.

8 AT e,

Jaguar F-Pace X761 (DolP)

PC o wa
— 3 N SAD CAZAX4K Guxded Diagnostics
— -
——
y - i Transmission
- = -_
) 3

Job card number

Campaigns

©  JaguarF-Paca XIGT(DolF) VIN SAD CAIAYANSESESS Mo yos 2018 Odmet 14878 1 O Shvelm 21V

At the next screen select the area where you have made the change and use Pathfinder to fix the
problem and update any required firmware.

B ST e 1733 ARNGS fsema- 553 1

B Guided Diagnosties
. - <

Where is the concern on the vehicle?

Criver assistancs syst

Exterior ie s

feror ecirica

e

Warming

i venicie Systems Unvesponsive

©  Jaguar F-Pace X761 (DolP) VIN: SAD CAZAXSS-oolied  Model year 2018 Odometer 14878 me @ v 121V

Alternatively, you can update ECU’s directly by entering ECU Diagnostics selecting the relevant ECU
and entering ECU functions as shown below.
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= ECU Disgrostics iotSnmENt MBStEr Contiolir [IMC List of ECU functions

<
List of ECU functions Q

Aliow Central Contguration D

@  Jaguar F-Pace X781 [DolP] VIN SAD CAZAX Model year 2019 Oomels 16716 i ) (G ) |‘

Select Allow Central Configuration Data Learning shown above or update the ECU whichever is
appropriate for that ECU as shown below.

I AT THDER i 113/3) v LPLNGE e

= ECU Dagnostics Passangsr Front Door Medule [POM] Listof ECU functions

@  JoguarFPace X761{DolP) VIN SAD CAZAN Modslyaar 2010 Odometsr 16716 mi O G |,;--|

Ensure after completion that you exit Pathfinder properly using the exit E option this will save any
changes back to the JLR servers so that next time you load Pathfinder it will be your modified file.

Please carefully read warning on last page of user guide 10



Using CCF Editor directly with SDD.

Start SDD in the normal way connected to the vehicle, click on the settings tab.
|spD Tedxs

Vehicle  Settings  Sessions
User Preferences  Dealer Information  System Information  System Utlties  On-Demand Fesdback
L System Utilities
Set Up
Network Options
Software Update
VCM Recovery Tool
Manual Patch Update
System
Run System Diagnostics
Vehicle calibration software
Combined as-built and calibration file update
Calibration file update only
As-built file update only
VIN based as-built file update
Speed test res;

1 30l 2020 1652 {14500 .330) Tho VCM s discemnicind.

Select VIN based as-built file update from the menu and enter the vehicle VIN number in the box as
shown in the next image.

To download As-Built files for a range of models select either ‘As-built file update only’ or ‘Combined
as-built and calibration file update’, select the range of models required to download from the
screens. !Warning! if you select both Jaguar and Land Rover and all models and years it will probably
take in excess of 36 hours to download all of the files. For vehicles older than 2012 selection by VIN
is not possible so selection by model and year is the only option.

Software management wizard ——

Toupdate as is/as buil files, enter all required VINs in the box below,

=t N ore VIN per line
Note: Thig option will only download ‘per VIN® as-is and as-buil files.
+ which is only applicable to cerlain wehiles
frmme SALVAZAE TFHI
Eutmaed dorkosd e
[ oo
Eussedine
o
| T1(1.5M) v
The estimated download time is based on pour intemet connection
speed. IF this is incomect please select the comect speed from the drop
dowen
Shaw details Net | Cancel

Click on Next this will initiate the download of the As-Built file from JLR, the result screen should
appear as below.

Software management wizard o]
Download SALVAZAE 7TFH a1 _As-Built zip
Coneection sess
Verification
[emp——
[ i
— Overall status
T
Total number of files to download = 0
| [T1(1.5M) ~ | MNumber of files successfully downloaded = 1
MNumber of files failed to download =0
File download completed
Show details Finish

Note: There may be minor variations in the screens dependent of the SDD version in use.

Please carefully read warning on last page of user guide 11



Click Finish to return to main window, minimise the SDD window and start the CCF editor. Click file
the Open as shown below. If the you are selectin the vbf from a single download As-built file the file
download is a zip file with the VIN_Number_As-Built.zip as the file name sometimes it may be
VIN_Number_AS_IS.zip, if you are selecting from the range of VINS downloaded the file format is
LNNN_YYYY_NN.zip for Land Rover and XNNN.YYYY.NN.zip for Jaguar which decodes as
Model_Year_Batch.

[ ccr Edit - m] x
File Edit Dump Help

Open Ctrl+0 Description
Save Ctrl+S  {UCD D01)VEHICLE TYPE ~
[UCD 002]DOORS
{UCD 003]1.C. Engine TRANSMISSION - DRIVELINE
Compare Ctrl+C UCD 004 JBIFUEL
Print Ctrl+p  UCD DOSJENGINE TYPE
{UCD 006JFUEL

Save As  Ctrl+N

Exs Ctrl+X  HiCh 007 JALTERNATOR
ss1 EUCD 008]  |[EUCD ODBJSTEERING WHEEL POSITION
567 EUCD009]  |[EUCD 00SJGEARBOX
583 EUCD 010]  |[EUCD 010]GEARBOXTYPE
599 EUCD 011 ELICD 011]FUEL TANK VOLUME
615 EUCD 012, EUCD 012]ALARM
631 EUCD 013 EUCD 013]SEAT MASSAGE
647 EUCD 014 EUCD 014]HEADLIGHTS TYPE
807 EUCD 015, EUCD 015]HEADLIGHTS SYMMETRY
823 EUCD 016, ELCD 016]DAYRUNNING LIGHT
839 EUCD 017 EUCD 017]DIMMED DIPPED HEADLIGHTS
855 EUCD 018, EUCD D18]FOGLIGHT FUNCTION
871 EUCD 019, EUCD D19]REAR FOGLIGHT TOW FUNCTION
887 EUCD 020, EUCD 020]TRAILER MODULE
903 | [EUCD021]  |[EUCD 021]KEYLESS ENTRY AND START v
< >
Select the desired zip file as per example.
|£/0pen x
Look In: ‘Ij SM_AS_BUILT - | [=][&][=] [E8]=
[ L5500v_2016_6.71P [} SALVA2AE7FHO89541_As Buit.ZIP [ X
[ Lss00v_2016_7.21P [ x150_2006_46.zip 0Ox
[ L5500v_2016_7_1.2IP [ x150_2006_47.2ip Ox
[ L5500V _2016_8.21P [ X150_2006_49.zip (AR
[} SADCAZAKIHA499005 As-Built.ZIP [ ] X150_2007_41.zip O«
[7) SAJAB4ANXHCPO7408_As-Built.ZIP [} X150_2007_42.zip Ox
« i O]
File Name: ‘
Files of Type: ‘VBF files -
Open Cancel

The window will change to another Open window showing the VBF files inside the zip file, select the
required zip file and click open.

£ open X

Look In: ||j SADCAZAK3HA499005_As-Built ‘v (=] [&][=][R8]5]

"D'I

File Name: SADCA2AKIHA499005.VBF

Files of Type: [VBF files [+]

oo ] e

The window will change after loading to show all parameters in CCF file, click on the parameter that
it is desired to change and from the drop down select the desired parameter and select Update.

Please carefully read warning on last page of user guide 12



Edit

Dump  Help

MOF .. Paameter
7543 [342[[ELCD 202]
343 [ELCD 203]
345 [EUCD 204]
7735346 [ELICD 205]
7751 347 [ELCD 206]
7767 (348 [ELCD 207]
7763|345 [EUCD 208]
7799 350|[ELCD 209]
7815 (351 [ELCD 210]
7675 361 [EUCD 211]
7991 362 [EUCD 212]
8007 363 [EUCD 213]
6073 364 [ELICD 214]
B39 1365 [ELICD 215]
a0ss 66 [ELCD 216]
6071 367 [ELCD 217]
6231365 [EUCD 218]
570 [EUCD 213]
371 [EUCD 220

Description
[EUCD 202) Solar Sensor

[EUCD 203] Telematics Protection

[ELICD 204] RETRACTABLE RUNNING BOARD
[EUCD 205] RACING SUB BRAND
[EUCD 206] Driver Workoad Manager
[EUCD 207] FRONT CAMERA

[ELICD 208] STEERING COLUMN LOCK
[ELICD 203] Wade Sensing

[Euco 210] BATTERY

[ELICD 211] BATTERY MONITOR SENSOR

[EUCD 212] REGION IF DVD

[(EUCD 213] Eca Data (Driver Information Display)
[ELICD 214] INTEGRATED CONTROL PANEL
[EUCD 215 Infotainment Theft Protsction
[EUCD 216] Quescent Relay Box

[ELICD 217] PICTURE SUPPORT

[EUCD 218] IGOR System Descripbion

[EUCD 215] LANGUAGE REGION

[EUCD 220] SIDE CAMERA

[(EUCD 224) ADJUSTABLE SPEED LIMITER
[EUCD 225] Advanced Chauffewr Funtion
[[EUCD 226] Inkeligent Emergency Braking
[ELICD 227] 4x4 Information Display

[EUCD 228] Audible Alarm Mode

[EUCD 229] Model Year

[ELICD 230] Crash Event Data Recording

[[EUCD 231] Door Latch Type

[EUCD 232] Auxilary Water Pump

\[EUCD 233] Part Number Format

[EUCD 234] Conversation Assist

[EUCD 235] Navigation ECO Ronte - URBAN data
[ELICD 236 Navigation ECO Roate - EXTRA URBAN data
[(EUCD 237] Transfer Box

[EUCD 238] Active Rol Control

[EUCD 235] Rear DIF

[ELICD 240] Amblent Lighting

[EUCD 241] Navigation Speed Inhibit

[EUCD 242] Passive Locking Eior Tanes.

[EUCD 243] Handbook

[EUCD 244] Connect and View

[ELICD 245] Dynamic-i

F 27]
388 [ELCD 228]
551 93 [ELCD 29]
5567390 [ELICD 230]
6583391 [ELICD 231]
5743 393 [ELCD 232
6759 394 |[EucD 233]
6775 1395 [ELCD 234]
87911396 [ELCD 235]
8807 1397 [£LICD 236]
5873 398 [ELICD 737)
6639 (395 [EUCD 236]
8999 409 [ELCD 239)
o015 1410/[ELICD 240]
9031411 [FLCD 241]
o047 412 [FLCD 2421
3063 413 [ELICD 243]
9079 (814 [ELICD 244]
9095 415|[ELCD 245]

EUCD20SRACINGSLIBERAND

0x01

5. Desciiption
(002 [Fronk - Single Zone : Rear - Nok fitted o
(003 Telematics Protacted
0x00 ot supported
0x01 Manstream Vehide
1000 ot supperted

[on01 Without Front Camerajs

(000 piot supported

0x01 (D001) Wiade Sensing Not Fitted 3

lox13 |H7 80Ah 800 Coki Cranking Ampere, AGM

(04002 Battery Mankor Sensor

003 [R2 EL/South Afiica For DVD

[0x04 Function enabled (Display Information kevel 3)

1000 ot supported

(0x00 piot supported

iox02 |QRE function enabled

ox01 |without Picture Support

0301 [2 Relay with Dumb logic

(000 ot supported

[ox01 [ without Side Camera

(000 ot supported

(0x02 Stop/Start

[0x01 jUD Not Freted

0x01 [ASL not Fitted

1000 [Undefned error condtion F used

[ox01 | without LSIER

0402 [Enabled

(0x02 [Enabled (Use avalable sounder)

lox1s 2015

(0200 lUndefined error condtion F used

Jox01 [C1 Latch

(001 [usrilary Waker Pump ok fitted

[ox01 0P Format

(Gx01 [Without Conversation Assist

[0x24 10x2%

Jou31 031

[ox01 [Single Speed wthout cantraller

(0x01 [ARC Not Fitted

0400 Undefined error condtion ¥ used
Marsts am vehide =
Jaguar R-Type
FFord S-TDCT
aguar RS subr-beand b
Jaguar R-Type 12MY Onwards
Range Roves RS
aguar 5 Sub-brand
VO LE Sub-brand -

Manstieam vehile -
—

Repeat the process for all parameter changes that are required. Once complete click file the save, it
maybe be useful to also do a ‘Save As’ so that the file can be used again later, make sure that the

‘Save As’ after a ‘Save’ as it is only the ‘Save’ option re-writes the zip file so it can be used by SDD.

The As-built file can be downloaded again as the downloaded file will always be the as factory
settings without any changes you have made if it is downloaded from JLR again.

Exit from CCF editor or just maximise the SDD window and select Recommendations from the top

bar. Scroll down until you see Car Configuration Management -Session Active car configuration

selection and select Run.

T

R & Recommendstions

I Recommendations

() service Functions
Type on

SSM SSMT1851 - Manual Service Re-Set Procedure for 14MY Vehicles

SERVICE checksheet

Type Description
@) | Missing ASBUILT data help quide

Tools

Special applications

Vehicle [EITTIECSTENY
e

Options

Read

Not read
Not mxd| Read ‘

Slatus.

Options

Read

Not read

Description

BB car configuration management - Current vehicle car configuration modification

Service

Stalus

Options

Executed | Run

Status

Type  Description

- Car configuration managemenl - Session aclive car configuration selection

14 Jul 2020 17:05 (169.07 v.339)

It will take some time click on the greén ticks when requested to, until the screen below is visible.

Options

Executed
v

The Gateway device

Please carefully read warning on last page of user guide
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SpD

P o @N

Vehicle [EITEC L

ST Recommendations

B

$ession entry car configuration summary
Active session active car configuration source is:GWM )

t
i

é

14.Jul 2020 17:05 (159,07 v.339)

The Gateway device Is Gisconnected.

Click on the tick to advance to the window below and select As Built as shown.

S5DD

P d@N

Venice

ES  Recommendations

§o

Active session car configuration data and alternate car configuration status

Withcut fuelfire heates
Biear air conditioning Rear fioor conscle with na re..
bavigticn High navigatien system with .
Power fold minors Fined
Lane departure marning Mo lane depaturewaming 0. (L}
Audia unit [radic) bandlrecuency setting Frequency band and step for .
Fiacio, smp and speskes tystem High performance
Audh player Single DD playes with MP3
biavigstion system Nsvigation system for Ewope =
Active session car configuration source is: GWM Fleset view
= ™ View al pasameiers
B [ viehicie Without el ir.. 0cd1
BcM 4 o |Body control module Vehicle backup module Without fuel fir... 001
s buitt file o saLvezngTeeemee veE Versatile binary file Without fuel fir.. 001

|l At

Select obher

i

< x

14 Jul 2020 17:05 (159.07 v.339)

The Gateway device is disconnected,

Click on the tick at the next window user preference difference will be shown any that require to be
kept, click on the corresponding arrow as shown. The left arrow is new settings the right is keep old
settings, this has to be done for each setting that is different. When complete click the green tick.

5DD

IEZZTIN Recommendations

HPe BN
Vehicle
e

List of personalisation parameters for copying

Wincishield wipers up-stroke wash

Take se

>

setting Keep current state

€ |

o User selected session active car configuration source is: As built file

vabae from rectthix

sct
s ek e oty doved vabas,

G [ oy Automati re-lo.. B2
s buil file B D savaaETFHIosH VBE Versatile binary file Undefined 00
wutomatic re-iocking

e vl ot yedt avarlable.

i

&)

14 Jul 2020 17:05 (168.07 v.339)

At the next screen click the green tick and the modified

Please carefully read warning on last page of user guide

The Gateway device is disconnectsd.

CCF will be downloaded to the vehicle.
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Q Operator question

Do you wish to download the vehicle configuration file?

t 4 ] X
—

SDD will attempt to upload required firmware changes to vehicle new modules may still need to be
configured as normal. Please again note that screens may differ slightly based on version of SDD.

Using CCF Editor on a different PC to Pathfinder or SDD

If the CCF editor is installed on a different PC to Pathfinder editing the ccf is only slightly different.
First start Pathfinder as normal and allow VIN to be read when the vehicle screen appears minimize
Pathfinder and using windows file explorer navigate to C:\users\<your
username>\AppData\local\temp. You will then need to double click on the folder name with the
vehicle VIN_extracted to open that folder. Copy the vbf file to a suitable USB stick. Then in the PC
with CCF editor installed copy the vbf file to your home directory which will be C:\Users\<your
username>. CCF editor will automatically go to this directory to open a vbf file if Pathfinder or SDD
are not installed. To put the vbf file back after editing the process is just the reverse the edited vbf
file must be saved into the VIN_extracted folder after Pathfinder is opened and connected to the
car. Alternatively download the vbf from the DFSM server make the required changes and upload to
the DFSM server, when Pathfinder reads the vehicle VIN it will download the latest As-IS file.

If using SDD the directory is
C:\ProgramData\JLR\IDS\Sessions\SOFTWARE_MANAGEMENT\SM_AS_BUILT and all vbf files are
inside zipped files either single vbf in one file or hundreds based on model, year and batch. When
opening a vbf from a zip file copy the whole zip file from the SDD machine to a USB stick and copy
into your home area on the PC then copy back after changes are made.

Please carefully read warning on last page of user guide 15



Dump Files

The following dumps of the ccf files are available, VBF dump (full file dump), CCF dump (ccf data
only), XMF dump will dump the as built XML file associated with the CCF if available. In Window
mode a separate window will open in Tabbed mode a new tab will open.

CF Edit- SADFLZGXOK 129855

b —t “xsen
mo 5 Doar
. E 0603l W] s T Gcommt]
a1
VEC_version = 2.2 nasc
01
meacier | T

ae_pact_muabs

“EIC- AR

pu - cancrs;
setuark = CRN_S:
au_saarens= BATISE

frame_ta;

it CAN_STANDNRDS

| 0%0000C000 , 2220000000 15

ackause  nddméziol;

o0 ou g 10 3¢

S23uBUERBIAR
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o1 e I
I Aaesmator 2308 I
DML et bang

(DAE0 5 Spees Autn Coarbin

002 putamarc gearbon.

10508 Fual Task Sl (ST

10900 Hon e

(100 M Seppon
(G902 Sandara dpped ight, en-GTAL)
060 s sepp

0+ Faghgm frore

(000 i seppoted

mg rader Ml

0807 Ketess Fetry A e

mo ol e aree

00z Ctoe commot T

supponed
10408 Elacic Rowss Stearig wih £K1erial e aad e corol ook ...
(000 Mo sepponed

i s
1001 Wt vt s
{04 £ s for g i 2 gt chr o s 2 a1 .
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CCF Edit- SADFLIGKSmnmseses.
[ value T

X540

5 Doar
003 ail wheel Drive (Wah disconnect)
001 Mot Bifuel

0x3C__|A)200P OR AIZL-P4 2.0 lise (4 Cylinder)
Perol

OxOC__|Alternatar 330A
001 Lef Hard Drwe
0x50 |9 Spmed Auto Gearbax

Ausumatc gearbox
008 Fusl Tank Smai (501
000 Mot supparted
0x0LSeat Massage ot fitted

0x08__|Maix LED non-AF5123nen-HE.
000 Nat Supparted
0x02 _Standard dipped ight. (Non-DTRLI

0x00 Mot supperted
F

0x02 Keyless Ertry And Start

0x01 [ Withous Fusl fired heater
002 Crusse Cantral
000 [N supparted

0x00 Mot supprted

[0x0A__[Electric Power Steering with external angle and forque corsrol_ordy for
000 Nat suppar
0x00__|Not supparted

003 |Electrical chi lock rear doors

0x04__|Ext scan for key priar/post to tallgate closurs - both opiions 2 and 3
lIngerior Scan for ANY KEY N VEHICLE 1o prevent chish of scans betase.
ried

Click on Find the first row with matching data will be highlighted as below. Find searches only in
columns parameter and parameter description.

Please carefully read warning on last page of user guide



ene CCF Edit- SADFL2GX Bl SISmre.

2851 Eucooot VEHICLE TrPE loxz7 %540
a2 eucooo2 |ocans loxz s

3273 kucooos ITRANSMISSION DRNELINE 0x03 A1 Wheel Drive (With disconnect

343 & Fucoona [mwuEL Jox01 wos 8ituel

358 5 kucooos [ENCINE TYPE loxdE A200% OF 21 -F4 2.0 live (4 Cyinden)

375 6 kucooos JFuEL [ pewsal

39 7 kucoooy ALTERKATOR 0a0C Aveinator 2304

5518 Fucooos [STEERING WHEEL POSITION |01 Lot Hand Drive

s67 16 Eucboos |cearBen |50 9 Speed Auto Ecarban

583 11 EUCDOI0 |GEARBOXTYPE [ox02  Aunomatic gearbx

599 12 kucooin IFLEL TANS WOLUME Qx08 | Fuel Tank Smal (500

B1s 13 Eucooi2 ] |00 Mot supported

631 14 kucpoid [SEAT MASSAGE |01 Seat Massage not Féied

647 15 EUCDO14 |HEADUGHTS TYPE [0x08 | Mavix LED non-AFS123ron-IH8

#0717 EUCDOIS HEADUGHTS SYMMETRY 0x00 | No Suppored

B2l 18 Eucnois [OAYRUNNINE LEHT 0x02  Seandard dimped ight (Nen-DTRL)

838 13 kucooir IOIMMED DFFED HEADLGHTS 0x00 Nk supported

855 20 Eucools [FOGUGHT ANCTION [ow04 Foalight Frant

87121 EucDois [REAR FOCLICHT TOW AINCTIN [0 w0t supparte:

887 22 fucnoio ITRAILER MODULE x01  Withourt Traiier Moduie.

903 23 kucoozn KEVLESS ENTRY AND START 0x02 Keyiss Entry A Start

1063 (33 FucDozz |ADDITIONAL HEATER {001 Wihout fust fired huater

1078 34 Eucpol3 |CRUISE CONTROL lox02  Cruise Coreral

1095 (35 kucnoad |nansenson [0 ot supported

1 36 kucoozs HEADUGHT CLEANING 0x00 Not supported

112737 Fucoozs |POWER STEERING TYFE |0x0a Eleciric Fower Sieering weh external angle and forque control anly for
1143 38 ucpea? [TRIP COMPUTER |00 Mot supparted

115539 FUcno28 PRIVATE LOCKING TAUNK 0x00 — Not supported

1335z EUCDOi0 IUNLOCK SETTIHG 0x02  Two siep opening

1351 43 Eucpodl |ACKOWL SIGNAL LOTK ALRM |00 Mot supported

1367 44 FucDo3z |AUTOMATIC LOTKING 8 SPEED. {000 wot supportes

1363 45 Eucooid ILEVEL SENSOR_IF ALARM o1 whout vl sensar

1399 a6 kucools ey lock in Protection? EXT (0x04 €t scan for key prior/past to tailgate closure - both optiors 2 and 3 .
1415 47 EUCDOIS [Key bock in Protection NT (003 intericn Scan for ANY KEY IN VEHICLE 1o prevent chash of scans betwes...
1575 (49 FuCDO3S [PANIC ALARM {000 Wos supported

1591 50 EUCDO3T |BLIND SPOT INFORMATION SYSTEM |ox07 aling Spat informatian Sysiem disabled wah ATO (Rear waffic decection)
1607 (51 kucnois [8OAD FRICTION DETECTION 0x00 Nok supported

1623 52 kucoois [FTC HEATER SUPPLEMENTARY AR HEATER [ox0z_wnh PYC heater

1633 53 EUCDO40 BATTERY REAR [0x09 Wos supported

1655 (54 EUCDOAL (COUPE FLTER lox00 ot supparted

1671 (55 kucnos2 ICLIMATE CONTRGL UNIT 0x09 | Dual Zome ATC

1831 (65 EUCD0S3 ED UMITAT 0x00|wos supported

1847 66 EUCDO4a SPEED WARNING DEVICE 0x00 Ho supparted

1861 67 EUCDO4S |NSTRUMENT CLUSTER CALIBRATION |0x00 ot supported

1879 (68 FUCDO4G WHEEL BRAKES TYPE FRONT 0x00[Not supported

1895 69 EuCDO4T INTERIR MOTION SENSOR 0x01  Wahour marior Movemans Sarer

91170 EUCHods  MEARTEAT Snson [0x00 [ supporied

To find again click on Edit->FindNext or F3 again to use the same search just click enter.
To Find all occurrence of the search term click on Edit->FindAll

Using Hex Editor

The Hex editor gives the facility to directly edit the binary data of the ccf if you must.

Open or download a vbf file as in previous sections. Click on Edit and then click on Hex Edit, this will
open the hex editor as shown below, or click on any row or use find to find a row click on Edit and
then click on Hex Edit this will open the hex editor with the cursor on the relevant byte in the CCF
file. If you change the data and click on update it will update the record on screen only you still need
to save the file in the normal way.

Window mode:
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Cancel 1
o e b
554 e 6 e a1
T
o 8w B
WAL 00 0 e
£ oo 00 00 ba . Mot o i
e b 00 w0 o " Bocrarge Lgens wi 3n )
o 80 w0 Supponid
e na
8 parna
e o s tcnoes I
Bwreen e o vt of wha e comecind oy e g o .|
a0 4 B 8 o R
i ddd6 i6 b0 B 65 Ga S0 6 o i2 21l
105 paten 55 56 35 55 65 55 55 s e 12 BV seUBCRI T
EUIEpaaiiE 44 25 85 a1 4B 11 31 5 e B0 B0 BB BB B al,
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Tabbed mode:

[# ccremas ~ o x
|Fie Edt Dump Help Updaie Cancsl -
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28E92EE 8
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Factory Default for NGI vehicles

For all vehicles that can be downloaded from the DFSM server two zips files are generally download
the As-Built zip and As-Is zip all uploads go back to the DFSM server as As-Is, so to reset to factory
build when downloading select the As-Built as the chosen vbf file and immediately upload this back
to the server this will save the factory default to the As-Is, Pathfinder or SDD can then be used to
upload this to the vehicle effectively resetting the vehicle to factory default.

Useful information

Pathfinder As Built directory — C:\users\<username>\AppData\local\temp

Pathfinder As Built directory — <VIN>_extracted this directory is downloaded from Topix every time
the VIN is read from the vehicle however after a save and successful load to the vehicle it will be
uploaded to JLR so changes made will be downloaded every time. It is an idea before changes are
made that a copy is made of the original as built file. The original As-Built file can be downloaded
using download.

SDD As Built directory -

C:\ProgramData\JLR\IDS\Sessions\SOFTWARE_ MANAGEMENT\SM_AS_BUILT

SDD As Built Files - <VIN>_AS Built.zip and Model _YEAR_Batch.zip files, the ccf editor will
automatically extract the selected vbf file and repack the file if it is opened using Open and then
saved using the Save option.

Note some as built files return with <VIN>_AS_IS.zip if the file is available. A VBF can be saved to a
USB stick and used with the Car Configuration Management tool by selecting other as the source for
the CCF.

The Editor when closing may wait for a period before fully exiting this is to clean up all temporary
stores created when open files and folders. It may also appear to take a long time open some of the
SDD zip archive files this is caused by the number of VINS in the file which can vary from one to
thousands depending on the batch number.

Compare will open the and load the first file into the table if one is not loaded this will disable
Upload and Copy to. After a file has been downloaded it can be compared to any VBF stored locally
this will not disable Upload and Copy to.

The license will not work if the system date is older than the license issue date, if you need to run
SDD with a specific date then run CCF Editor on a different PC.

WARNING:

Editing the CCF of a vehicle can be dangerous and can cause damage to the vehicle if being carried
out by unskilled people. If there is any doubt about the changes being made DO NOT UPLOAD TO
THE VEHICLE.
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